$re = '/(?<="),/';
$str = '["Sender", "mail@text.org"]
[["Sender", "mail@text.org"], ["Date", "Fri, 09 Jun 2017 13:29:22 +0000"]]
[["Sender", "mail@text.org"], ["Date", "Fri, 09 Jun 2017 13:29:22 +0000"], ["Name", "Dude"]]';
$subst = ":";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;