# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\"),"
test_str = ("[\"Sender\", \"mail@text.org\"]\n"
"[[\"Sender\", \"mail@text.org\"], [\"Date\", \"Fri, 09 Jun 2017 13:29:22 +0000\"]]\n\n"
"[[\"Sender\", \"mail@text.org\"], [\"Date\", \"Fri, 09 Jun 2017 13:29:22 +0000\"], [\"Name\", \"Dude\"]]")
subst = ":"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.