const regex = /(?<="),/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<="),', 'g')
const str = `["Sender", "mail@text.org"]
[["Sender", "mail@text.org"], ["Date", "Fri, 09 Jun 2017 13:29:22 +0000"]]
[["Sender", "mail@text.org"], ["Date", "Fri, 09 Jun 2017 13:29:22 +0000"], ["Name", "Dude"]]`;
const subst = `:`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);