import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\"),";
final String string = "[\"Sender\", \"mail@text.org\"]\n"
+ "[[\"Sender\", \"mail@text.org\"], [\"Date\", \"Fri, 09 Jun 2017 13:29:22 +0000\"]]\n\n"
+ "[[\"Sender\", \"mail@text.org\"], [\"Date\", \"Fri, 09 Jun 2017 13:29:22 +0000\"], [\"Name\", \"Dude\"]]";
final String subst = ":";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}