#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\<a\b(?![^>]*\bnosecure\b)[^>]*>([^<]*)<\/a>"
Local $sString = "== secure / find:" & @CRLF & _
"<a href="mailto:test@test.com">test@test.com</a>" & @CRLF & _
"<a href="mailto:test@test.com" something="else">test@test.com</a>" & @CRLF & _
"<a something="else" href="mailto:test@test.com">test@test.com</a>" & @CRLF & _
"<a something="else" href="mailto:test@test.com" something="else">test@test.com</a>" & @CRLF & _
"" & @CRLF & _
"== no secure / find NOT:" & @CRLF & _
"<a href="mailto:test@test.com" nosecure>test@test.com</a>" & @CRLF & _
"<a nosecure href="mailto:test@test.com">test@test.com</a>" & @CRLF & _
"<a href="mailto:test@test.com" nosecure="true">test@test.com</a>" & @CRLF & _
"<a nosecure="true" href="mailto:test@test.com">test@test.com</a>" & @CRLF & _
"<a something="else" href="mailto:test@test.com" something="else" nosecure="true" something="else">test@test.com</a>" & @CRLF & _
"<a something="else" nosecure="true" something="else" href="mailto:test@test.com" something="else">test@test.com</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")