# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\<a\b(?![^>]*\bnosecure\b)[^>]*>([^<]*)<\/a>"
test_str = ("== secure / find:\n"
"<a href=\"mailto:test@test.com\">test@test.com</a>\n"
"<a href=\"mailto:test@test.com\" something=\"else\">test@test.com</a>\n"
"<a something=\"else\" href=\"mailto:test@test.com\">test@test.com</a>\n"
"<a something=\"else\" href=\"mailto:test@test.com\" something=\"else\">test@test.com</a>\n\n"
"== no secure / find NOT:\n"
"<a href=\"mailto:test@test.com\" nosecure>test@test.com</a>\n"
"<a nosecure href=\"mailto:test@test.com\">test@test.com</a>\n"
"<a href=\"mailto:test@test.com\" nosecure=\"true\">test@test.com</a>\n"
"<a nosecure=\"true\" href=\"mailto:test@test.com\">test@test.com</a>\n"
"<a something=\"else\" href=\"mailto:test@test.com\" something=\"else\" nosecure=\"true\" something=\"else\">test@test.com</a>\n"
"<a something=\"else\" nosecure=\"true\" something=\"else\" href=\"mailto:test@test.com\" something=\"else\">test@test.com</a>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.