use strict;
my $str = '== secure / find:
<a href="mailto:test@test.com">test@test.com</a>
<a href="mailto:test@test.com" something="else">test@test.com</a>
<a something="else" href="mailto:test@test.com">test@test.com</a>
<a something="else" href="mailto:test@test.com" something="else">test@test.com</a>
== no secure / find NOT:
<a href="mailto:test@test.com" nosecure>test@test.com</a>
<a nosecure href="mailto:test@test.com">test@test.com</a>
<a href="mailto:test@test.com" nosecure="true">test@test.com</a>
<a nosecure="true" href="mailto:test@test.com">test@test.com</a>
<a something="else" href="mailto:test@test.com" something="else" nosecure="true" something="else">test@test.com</a>
<a something="else" nosecure="true" something="else" href="mailto:test@test.com" something="else">test@test.com</a>';
my $regex = qr/\<a\b(?![^>]*\bnosecure\b)[^>]*>([^<]*)<\/a>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}