import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<a\\b(?![^>]*\\bnosecure\\b)[^>]*>([^<]*)<\\/a>";
final String string = "== secure / find:\n"
+ "<a href=\"mailto:test@test.com\">test@test.com</a>\n"
+ "<a href=\"mailto:test@test.com\" something=\"else\">test@test.com</a>\n"
+ "<a something=\"else\" href=\"mailto:test@test.com\">test@test.com</a>\n"
+ "<a something=\"else\" href=\"mailto:test@test.com\" something=\"else\">test@test.com</a>\n\n"
+ "== no secure / find NOT:\n"
+ "<a href=\"mailto:test@test.com\" nosecure>test@test.com</a>\n"
+ "<a nosecure href=\"mailto:test@test.com\">test@test.com</a>\n"
+ "<a href=\"mailto:test@test.com\" nosecure=\"true\">test@test.com</a>\n"
+ "<a nosecure=\"true\" href=\"mailto:test@test.com\">test@test.com</a>\n"
+ "<a something=\"else\" href=\"mailto:test@test.com\" something=\"else\" nosecure=\"true\" something=\"else\">test@test.com</a>\n"
+ "<a something=\"else\" nosecure=\"true\" something=\"else\" href=\"mailto:test@test.com\" something=\"else\">test@test.com</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}