using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<a\b(?![^>]*\bnosecure\b)[^>]*>([^<]*)<\/a>";
string input = @"== secure / find:
<a href=""mailto:test@test.com"">test@test.com</a>
<a href=""mailto:test@test.com"" something=""else"">test@test.com</a>
<a something=""else"" href=""mailto:test@test.com"">test@test.com</a>
<a something=""else"" href=""mailto:test@test.com"" something=""else"">test@test.com</a>
== no secure / find NOT:
<a href=""mailto:test@test.com"" nosecure>test@test.com</a>
<a nosecure href=""mailto:test@test.com"">test@test.com</a>
<a href=""mailto:test@test.com"" nosecure=""true"">test@test.com</a>
<a nosecure=""true"" href=""mailto:test@test.com"">test@test.com</a>
<a something=""else"" href=""mailto:test@test.com"" something=""else"" nosecure=""true"" something=""else"">test@test.com</a>
<a something=""else"" nosecure=""true"" something=""else"" href=""mailto:test@test.com"" something=""else"">test@test.com</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}