import Foundation
let pattern = #"\<a\b(?![^>]*\bnosecure\b)[^>]*>([^<]*)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
== secure / find:
<a href="mailto:test@test.com">test@test.com</a>
<a href="mailto:test@test.com" something="else">test@test.com</a>
<a something="else" href="mailto:test@test.com">test@test.com</a>
<a something="else" href="mailto:test@test.com" something="else">test@test.com</a>
== no secure / find NOT:
<a href="mailto:test@test.com" nosecure>test@test.com</a>
<a nosecure href="mailto:test@test.com">test@test.com</a>
<a href="mailto:test@test.com" nosecure="true">test@test.com</a>
<a nosecure="true" href="mailto:test@test.com">test@test.com</a>
<a something="else" href="mailto:test@test.com" something="else" nosecure="true" something="else">test@test.com</a>
<a something="else" nosecure="true" something="else" href="mailto:test@test.com" something="else">test@test.com</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)