re = /\<a\b(?![^>]*\bnosecure\b)[^>]*>([^<]*)<\/a>/
str = '== secure / find:
<a href="mailto:test@test.com">test@test.com</a>
<a href="mailto:test@test.com" something="else">test@test.com</a>
<a something="else" href="mailto:test@test.com">test@test.com</a>
<a something="else" href="mailto:test@test.com" something="else">test@test.com</a>
== no secure / find NOT:
<a href="mailto:test@test.com" nosecure>test@test.com</a>
<a nosecure href="mailto:test@test.com">test@test.com</a>
<a href="mailto:test@test.com" nosecure="true">test@test.com</a>
<a nosecure="true" href="mailto:test@test.com">test@test.com</a>
<a something="else" href="mailto:test@test.com" something="else" nosecure="true" something="else">test@test.com</a>
<a something="else" nosecure="true" something="else" href="mailto:test@test.com" something="else">test@test.com</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end