#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z]+(_?[A-Za-z0-9]+)*$"
Local $sString = "name_1_test_test_test" & @CRLF & _
"name_1_" & @CRLF & _
"name_1" & @CRLF & _
"1_test" & @CRLF & _
"1a_test_tt" & @CRLF & _
"_test" & @CRLF & _
"test_" & @CRLF & _
"t" & @CRLF & _
"test_test" & @CRLF & _
"t_test" & @CRLF & _
"test_t" & @CRLF & _
"a_b" & @CRLF & _
"" & @CRLF & _
"n3ame__2" & @CRLF & _
"_name3" & @CRLF & _
"name4_"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")