const regex = /^[A-Za-z]+(_?[A-Za-z0-9]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z]+(_?[A-Za-z0-9]+)*$', 'gm')
const str = `name_1_test_test_test
name_1_
name_1
1_test
1a_test_tt
_test
test_
t
test_test
t_test
test_t
a_b
n3ame__2
_name3
name4_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}