package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]+(_?[A-Za-z0-9]+)*$`)
var str = `name_1_test_test_test
name_1_
name_1
1_test
1a_test_tt
_test
test_
t
test_test
t_test
test_t
a_b
n3ame__2
_name3
name4_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}