import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z]+(_?[A-Za-z0-9]+)*$";
final String string = "name_1_test_test_test\n"
+ "name_1_\n"
+ "name_1\n"
+ "1_test\n"
+ "1a_test_tt\n"
+ "_test\n"
+ "test_\n"
+ "t\n"
+ "test_test\n"
+ "t_test\n"
+ "test_t\n"
+ "a_b\n\n"
+ "n3ame__2\n"
+ "_name3\n"
+ "name4_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}