$re = '/^[A-Za-z]+(_?[A-Za-z0-9]+)*$/m';
$str = 'name_1_test_test_test
name_1_
name_1
1_test
1a_test_tt
_test
test_
t
test_test
t_test
test_t
a_b
n3ame__2
_name3
name4_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);