# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Za-z]+(_?[A-Za-z0-9]+)*$"
test_str = ("name_1_test_test_test\n"
"name_1_\n"
"name_1\n"
"1_test\n"
"1a_test_tt\n"
"_test\n"
"test_\n"
"t\n"
"test_test\n"
"t_test\n"
"test_t\n"
"a_b\n\n"
"n3ame__2\n"
"_name3\n"
"name4_")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.