using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z]+(_?[A-Za-z0-9]+)*$";
string input = @"name_1_test_test_test
name_1_
name_1
1_test
1a_test_tt
_test
test_
t
test_test
t_test
test_t
a_b
n3ame__2
_name3
name4_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}