#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)" & @CRLF & _
"([^\d]+) # Person's Name" & @CRLF & _
"(.*(?:st|av|blvd|rd))\.?\h* # Number and Street" & @CRLF & _
"(.*?),?\h* # City" & @CRLF & _
"([A-Z]{2}),?\h* # State" & @CRLF & _
"(\d+) #Zip code"
Local $sString = "Frank Conte 2133 Elm St. Gainesville, FL, 45679." & @CRLF & _
"Frank F. Conte 123 First Rd. New York NY, 12345." & @CRLF & _
"Frank Conte 2133 Elm blvd Gainesville fl, 45679." & @CRLF & _
"Frank Conte 2133 Elm av Gaines Town, FL, 45679"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")