import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ix)\n"
+ "([^\\d]+) # Person's Name\n"
+ "(.*(?:st|av|blvd|rd))\\.?\\h* # Number and Street\n"
+ "(.*?),?\\h* # City\n"
+ "([A-Z]{2}),?\\h* # State\n"
+ "(\\d+) #Zip code";
final String string = "Frank Conte 2133 Elm St. Gainesville, FL, 45679.\n"
+ "Frank F. Conte 123 First Rd. New York NY, 12345.\n"
+ "Frank Conte 2133 Elm blvd Gainesville fl, 45679.\n"
+ "Frank Conte 2133 Elm av Gaines Town, FL, 45679";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}