use strict;
my $str = 'Frank Conte 2133 Elm St. Gainesville, FL, 45679.
Frank F. Conte 123 First Rd. New York NY, 12345.
Frank Conte 2133 Elm blvd Gainesville fl, 45679.
Frank Conte 2133 Elm av Gaines Town, FL, 45679';
my $regex = qr/(?ix)
([^\d]+) # Person's Name
(.*(?:st|av|blvd|rd))\.?\h* # Number and Street
(.*?),?\h* # City
([A-Z]{2}),?\h* # State
(\d+) #Zip code/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}