$re = '/(?ix)
([^\d]+) # Person\'s Name
(.*(?:st|av|blvd|rd))\.?\h* # Number and Street
(.*?),?\h* # City
([A-Z]{2}),?\h* # State
(\d+) #Zip code/';
$str = 'Frank Conte 2133 Elm St. Gainesville, FL, 45679.
Frank F. Conte 123 First Rd. New York NY, 12345.
Frank Conte 2133 Elm blvd Gainesville fl, 45679.
Frank Conte 2133 Elm av Gaines Town, FL, 45679';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);