// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ix)
([^\d]+) # Person's Name
(.*(?:st|av|blvd|rd))\.?\h* # Number and Street
(.*?),?\h* # City
([A-Z]{2}),?\h* # State
(\d+) #Zip code").unwrap();
let string = "Frank Conte 2133 Elm St. Gainesville, FL, 45679.
Frank F. Conte 123 First Rd. New York NY, 12345.
Frank Conte 2133 Elm blvd Gainesville fl, 45679.
Frank Conte 2133 Elm av Gaines Town, FL, 45679";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}