package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ix)
([^\d]+) # Person's Name
(.*(?:st|av|blvd|rd))\.?\h* # Number and Street
(.*?),?\h* # City
([A-Z]{2}),?\h* # State
(\d+) #Zip code`)
var str = `Frank Conte 2133 Elm St. Gainesville, FL, 45679.
Frank F. Conte 123 First Rd. New York NY, 12345.
Frank Conte 2133 Elm blvd Gainesville fl, 45679.
Frank Conte 2133 Elm av Gaines Town, FL, 45679`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}