import Foundation
let pattern = ##"""
(?ix)
([^\d]+) # Person's Name
(.*(?:st|av|blvd|rd))\.?\h* # Number and Street
(.*?),?\h* # City
([A-Z]{2}),?\h* # State
(\d+) #Zip code
"""##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Frank Conte 2133 Elm St. Gainesville, FL, 45679.
Frank F. Conte 123 First Rd. New York NY, 12345.
Frank Conte 2133 Elm blvd Gainesville fl, 45679.
Frank Conte 2133 Elm av Gaines Town, FL, 45679
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)