#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"#(?=.*?\bmust-have\b)" & @CRLF & _
"#(?=.*?\bmandatory\b)" & @CRLF & _
"(" & @CRLF & _
"#(?!avoid|illegal|\t)." & @CRLF & _
"(?!\t)." & @CRLF & _
")*" & @CRLF & _
"$"
Local $sString = " must-have mandatory" & @CRLF & _
" must-have mandatory avoid" & @CRLF & _
" must-have mandatory avoid has a tab"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")