package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
#(?=.*?\bmust-have\b)
#(?=.*?\bmandatory\b)
(
#(?!avoid|illegal|\t).
(?!\t).
)*
$`)
var str = ` must-have mandatory
must-have mandatory avoid
must-have mandatory avoid has a tab`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}