const regex = /^
#(?=.*?\bmust-have\b)
#(?=.*?\bmandatory\b)
(
#(?!avoid|illegal|\t).
(?!\t).
)*
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
#(?=.*?\\bmust-have\\b)
#(?=.*?\\bmandatory\\b)
(
#(?!avoid|illegal|\\t).
(?!\\t).
)*
$', 'gm')
const str = ` must-have mandatory
must-have mandatory avoid
must-have mandatory avoid has a tab`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}