use strict;
my $str = ' must-have mandatory
must-have mandatory avoid
must-have mandatory avoid has a tab';
my $regex = qr/^
#(?=.*?\bmust-have\b)
#(?=.*?\bmandatory\b)
(
#(?!avoid|illegal|\t).
(?!\t).
)*
$/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}