$re = '/^
#(?=.*?\bmust-have\b)
#(?=.*?\bmandatory\b)
(
#(?!avoid|illegal|\t).
(?!\t).
)*
$/mx';
$str = ' must-have mandatory
must-have mandatory avoid
must-have mandatory avoid has a tab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);