re = /^
#(?=.*?\bmust-have\b)
#(?=.*?\bmandatory\b)
(
#(?!avoid|illegal|\t).
(?!\t).
)*
$/mx
str = ' must-have mandatory
must-have mandatory avoid
must-have mandatory avoid has a tab'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end