using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^
#(?=.*?\bmust-have\b)
#(?=.*?\bmandatory\b)
(
#(?!avoid|illegal|\t).
(?!\t).
)*
$";
string input = @" must-have mandatory
must-have mandatory avoid
must-have mandatory avoid has a tab";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}