#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Za-z0-9_-]+@mycompany\.com"
Local $sString = "user@mycompany.com" & @CRLF & _
"user@anothercompany.com" & @CRLF & _
"user-123@mycompany.com" & @CRLF & _
"first-last@mycompany.com" & @CRLF & _
"first_last@mycompany.com" & @CRLF & _
"user22!@mycompany.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")