package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Za-z0-9_-]+@mycompany\.com`)
var str = `user@mycompany.com
user@anothercompany.com
user-123@mycompany.com
first-last@mycompany.com
first_last@mycompany.com
user22!@mycompany.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}