// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Za-z0-9_-]+@mycompany\.com").unwrap();
let string = "user@mycompany.com
user@anothercompany.com
user-123@mycompany.com
first-last@mycompany.com
first_last@mycompany.com
user22!@mycompany.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}