import Foundation
let pattern = #"[A-Za-z0-9_-]+@mycompany\.com"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
user@mycompany.com
user@anothercompany.com
user-123@mycompany.com
first-last@mycompany.com
first_last@mycompany.com
user22!@mycompany.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)