import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z0-9_-]+@mycompany\\.com";
final String string = "user@mycompany.com\n"
+ "user@anothercompany.com\n"
+ "user-123@mycompany.com\n"
+ "first-last@mycompany.com\n"
+ "first_last@mycompany.com\n"
+ "user22!@mycompany.com\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}