import re
regex = re.compile(r"[A-Za-z0-9_-]+@mycompany\.com")
test_str = ("user@mycompany.com\n"
"user@anothercompany.com\n"
"user-123@mycompany.com\n"
"first-last@mycompany.com\n"
"first_last@mycompany.com\n"
"user22!@mycompany.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")