#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\((?:[^()]++|(?1))*\))$"
Local $sString = "Bad:" & @CRLF & _
"1 + 2" & @CRLF & _
"(3 + 4) + 5" & @CRLF & _
"(1 + 2) + (6 + 7)" & @CRLF & _
"Good:" & @CRLF & _
"" & @CRLF & _
"(9 + 10)" & @CRLF & _
"(100 + (6 / 3))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")