import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\((?:[^()]++|(?1))*\\))$";
final String string = "Bad:\n"
+ "1 + 2\n"
+ "(3 + 4) + 5\n"
+ "(1 + 2) + (6 + 7)\n"
+ "Good:\n\n"
+ "(9 + 10)\n"
+ "(100 + (6 / 3))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}