package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\((?:[^()]++|(?1))*\))$`)
var str = `Bad:
1 + 2
(3 + 4) + 5
(1 + 2) + (6 + 7)
Good:
(9 + 10)
(100 + (6 / 3))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}