$re = '/^(\((?:[^()]++|(?1))*\))$/m';
$str = 'Bad:
1 + 2
(3 + 4) + 5
(1 + 2) + (6 + 7)
Good:
(9 + 10)
(100 + (6 / 3))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);