const regex = /^(\((?:[^()]++|(?1))*\))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\((?:[^()]++|(?1))*\\))$', 'gm')
const str = `Bad:
1 + 2
(3 + 4) + 5
(1 + 2) + (6 + 7)
Good:
(9 + 10)
(100 + (6 / 3))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}