re = /^(\((?:[^()]++|(?1))*\))$/m
str = 'Bad:
1 + 2
(3 + 4) + 5
(1 + 2) + (6 + 7)
Good:
(9 + 10)
(100 + (6 / 3))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end