// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\((?:[^()]++|(?1))*\))$").unwrap();
let string = "Bad:
1 + 2
(3 + 4) + 5
(1 + 2) + (6 + 7)
Good:
(9 + 10)
(100 + (6 / 3))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}