# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\((.*)\).*?\(?\1\)?/(\1)/gm;t' <<< "Chiaro Gallo (blabla) (blabla)
Ricard Michaeln ()
Marco Liu (Hong Kong Stock Co Ltd) Hong Kong Stock Co Ltd
Rafiq (Kkska Traning Co (p) Ltd) Kkska Traning Co (p) Ltd
"