import re
regex = re.compile(r"\((.*)\).*?\(?\1\)?", flags=re.MULTILINE)
test_str = ("Chiaro Gallo (blabla) (blabla)\n"
"Ricard Michaeln ()\n"
"Marco Liu (Hong Kong Stock Co Ltd) Hong Kong Stock Co Ltd\n"
"Rafiq (Kkska Traning Co (p) Ltd) Kkska Traning Co (p) Ltd\n")
subst = "(\\1)"
result = regex.sub(subst, test_str)
if result:
print(result)