#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\((.*)\).*?\(?\1\)?"
Local $sString = "Chiaro Gallo (blabla) (blabla)" & @CRLF & _
"Ricard Michaeln ()" & @CRLF & _
"Marco Liu (Hong Kong Stock Co Ltd) Hong Kong Stock Co Ltd" & @CRLF & _
"Rafiq (Kkska Traning Co (p) Ltd) Kkska Traning Co (p) Ltd" & @CRLF & _
""
Local $sSubst = "(\1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)