$re = '/\((.*)\).*?\(?\1\)?/m';
$str = 'Chiaro Gallo (blabla) (blabla)
Ricard Michaeln ()
Marco Liu (Hong Kong Stock Co Ltd) Hong Kong Stock Co Ltd
Rafiq (Kkska Traning Co (p) Ltd) Kkska Traning Co (p) Ltd
';
$subst = "(\1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;