using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((.*)\).*?\(?\1\)?";
string substitution = @"(\1)";
string input = @"Chiaro Gallo (blabla) (blabla)
Ricard Michaeln ()
Marco Liu (Hong Kong Stock Co Ltd) Hong Kong Stock Co Ltd
Rafiq (Kkska Traning Co (p) Ltd) Kkska Traning Co (p) Ltd
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}